dongnan
总版主
总版主
  • 粉丝52
  • 发帖数2198
  • 铜币14124枚
  • 威望6134点
  • 银元155个
  • 社区居民
  • 最爱沙发
  • 忠实会员
  • 喜欢达人
  • 原创写手
阅读:3437回复:0

h3c交换机命令

楼主#
更多 发布于:2013-05-08 09:50
h3c交换机-初级命令


实验环境
交换机
h3c S3600-28TP-SI
h3c S5024E

参考文档
H3C_S3600_v1510 手册
H3C_S5000E 手册
网上其他热心网友的配置文档

原理(重要)

为什么要划分Vlan?
传统的以太网是一个广播型网络,网络中的所有主机通过 HUB 或交换机相连,处在同一个广播域中
HUB 是物理层设备,没有交换功能,接收的报文会向所有端口转发;
交换机是链路层设备,具备根据报文的目的 MAC 地址进行转发的能力,但在收到广播报文或未知单播报文
(报文的目的 MAC 地址不在交换机 MAC 地址表中)时,也会向除报文进入端口之外的所有端口转发,为解决以太网交换机在 LAN 中无法限制广播的问题,出现了 VLAN(Virtual LocalArea Network,虚拟局域网)技术。
VLAN把一个物理上的LAN划分成多个逻辑上的LAN,每个VLAN是一个广播域
VLAN内的主机间通信就和在一个LAN内一样,不同VLAN内的主机不能直接通信

Vlan优点
与传统以太网相比,VLAN 具有如下的优点:
广播被限制在一个 VLAN 内,节省了带宽,提高了网络处理能力。
增强了 LAN 的安全性。VLAN 间不能直接通信,如果要访问需要通过路由器或三层交换机等三层设备。

Vlan原理
要使交换机能够分辨不同 VLAN 的报文,需要在报文中添加标识 VLAN 的字段由于交换机工作在第二层,只能对报文的数据链路层封装进行识别。因此,如果添加识别字段,也需要添加到数据链路层封装中。
IEEE 于 1999 年颁布了用以标准化 VLAN 实现方案的 IEEE 802.1Q 协议标准草案,对带有 VLAN 标识的报文结构进行了统一规定。
传统以太网帧封装格式
|DA&SA|Type|#####DATA######|
DA表示目的MAC地址,SA表示源MAC地址,TYPE表示协议类型,DATA表示数据。
IEEE 802.1Q 协议规定在目的 MAC 地址和源 MAC 地址之后封装 4 个字节的 VLAN Tag,用以标识 VLAN 的相关信息。
|DA&SA|Vlan Tag;TPID;Prioriy;CFI;Vlan ID;|TYPE|#####DATA######|
重要 VLAN ID
VLAN ID 标识该报文所属 VLAN 的编号,长度为 12bit,取值范围为 0~4095。
由于 0 和 4095 通常不使用,所以 VLAN ID 的取值范围一般为 1~4094。
交换机利用 VLAN ID 来识别报文所属的 VLAN,当接收到的报文不携带 VLAN Tag时,交换机会为该报文封装带有
接收端口缺省 VLAN ID 的 VLAN Tag,将报文划分到接收端口的缺省 VLAN 中传输。


以太网端口

以太网端口链路类型有三种:
Access 类型:端口只能属于1 个VLAN,一般用于连接计算机;
Trunk 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,一般用于交换机之间的连接;
Hybrid 类型:端口可以属于多个VLAN,可以接收和发送多个VLAN 的报文,可以用于交换机之间连接,也可以用于连接用户的计算机。
用户可以将当前以太网端口加入到指定的 VLAN 中。执行该配置以后,以太网端口
就可以转发指定 VLAN 的报文,从而实现本交换机上的 VLAN 与对端交换机上相同VLAN 的互通。
trunk类型,可以同时承载多个VLAN通过,只允许默认VLAN不打标,access只能承载单个VLAN,hybrid,可以同时承载多个VLAN通过,允许多个VLAN不打标。
(在端口模式)命令格式:
port link-type { access | trunk | hybrid }
缺省值:缺省为关闭vlan trunk功能
通过TRUNK口可以实现不同交换机上的相同VLAN的互通,可以通过多个VLAN的流量

命令行视图相关
用户视图
<h3c>                           #连接交换机后进入用户视图
系统视图            
<h3c>system-view                #进入系统视图
[H3C]                           #当前为系统视图
vlan视图
[H3C]vlan 2                     #进入vlan视图
[H3C-Vlan2]                     #当前为vlan视图
vlan接口视图
[H3C-Vlan2]quit                 #返回到系统视图
[H3C]interface vlan-interface 2 #进入vlan接口视图
[H3C-Vlan-interface2]           #当前为vlan接口视图
[H3C-Vlan-interface2]quit       #返回到系统视图
以太网端口视图
[H3C]interface GigabitEthernet 0/1 #进入端口视图
[H3C-GigabitEthernet0/1]        #当前为端口视图

帮助相关
任一视图下,键入 ? 获取该视图下所有的命令及其简单描述
<h3c>?
  debugging    Enable system debugging functions
  display      Display current system information
  ping         Ping function
  quit         Exit from current command view
  reboot       Reset switch
  reset        Reset operation
  save         Save current configuration
  system-view  Enter the system view
  undo         Cancel current setting
键入一命令,后接以空格分隔的“?”,如果该命令行位置有关键字,则列出全部关键字及其简单描述。
<h3c>ping ?
   -c       Specify the number of echo requests to send
   -s       Specify the number of data bytes to send
   X.X.X.X  Destination IP address
键入命令的某个关键字的前几个字母,按下<tab>键,如果以输入字母开头的关键字唯一,则可以显示出完整的关键字
<h3c>pi?
    ping

Vlan 相关

创建并进入vlan视图 或删除 vlan
vlan 2
undo vlan 2 [undo vlan all]
将access端口加入指定vlan
system-view/vlan 2/视图下执行
port GigabitEthernet 0/2
port GigabitEthernet 0/3 to GigabitEthernet 0/4 (3-4端口) 或者下条语句
port GigabitEthernet 0/3 GigabitEthernet 0/4
将access端口从 vlan 删除
system-view/vlan 2/视图下执行
undo port GigabitEthernet 0/2
vlan 3/视图下执行
undo port GigabitEthernet 0/3 to GigabitEthernet 0/6
创建并进入vlan接口视图
interface Vlan-interface 2
配置vlan接口 IP地址
system-view/vlan 2/接口视图下执行
ip address 192.168.9.1 255.255.255.0
vlan接口 指定网关。
ip gateway 192.168.9.1

配置管理的VLAN,缺省是VLAN 1
management-vlan 3                             #指定vlan 3 为管理的vlan
ip route-static 0.0.0.0 0.0.0.0 192.168.0.2   #增加一条缺省路由
显示vlan 设置
display vlan 3                                #vlan
display vlan all
display interface vlan-interface 3            #vlan接口
display ip interface vlan-interface 3         #vlan ip地址
display ip routing-table [verbose]            #查看路由表摘要信息,[verbose为详细信息]

以太网端口相关
更改端口类型为trunk (目的 不同交换机上的相同VLAN的互通)
[H3C101]interface GigabitEthernet 0/2               #进入端口视图
[H3C101-GigabitEthernet0/2]port link-type ?         #? 获得 port命令帮助                              
   access  Access link-type                                                      
   hybrid  Specify current hybrid port's characteristics                        
   trunk   VLAN trunk link-type                                                                                        
[H3C101-GigabitEthernet0/2]port link-type trunk     #指定端口类型为trunk                            
[h3c101]display interface GigabitEthernet 0/2       #显示指定端口信息 (省略了一大部分)
........................
PVID: 1                                                                        
 Mdi type: auto                                                                  
 Port link-type: trunk                                                          
  VLAN passing : 1 (default)                                                    
  VLAN allowed : 1 (default)
Trunk port encapsulation: IEEE 802.1q                                                    
.........................
允许其它 vlan的报文通过 Trunk 端口
[h3c101-GigabitEthernet0/2]port trunk permit vlan 200 300  #加入 vlan 200 300
[h3c101-GigabitEthernet0/2]display interface GigabitEthernet 0/2
 PVID: 1                                                                          
 Mdi type: auto                                                                  
 Port link-type: trunk                                                            
  VLAN passing : 1 (default), 200,300                                            
  VLAN allowed : 1 (default), 200,300                                            
  Trunk port encapsulation: IEEE 802.1q    
配置端口 GigabitEthernet0/2 的缺省 VLAN ID 为 1
[h3c101-GigabitEthernet0/2]port trunk pvid vlan 1            

用户相关
设置 telnet 用户密码
[H3C]user-interface vty 0
[H3C-vty0]set authentication password dongnan
设置web用户名与密码
[H3C]localuser admin admin 1
显示当前用户配置
[H3C]display user-interface
   Idx    Type     Tx/Rx
   0      AUX 0    9600
 + 1      VTY 0  
   2      VTY 1  
 + 3      WEB 0  
   4      WEB 1  
   5      WEB 2  
   6      WEB 3  
  +    : Current user-interface is active.
   F    : Current user-interface is active and work in async mode.
   Idx  : Absolute index of user-interface.
   Type : Type and relative index of user-interface.

错误相关
[H3C]interface vlan-interface 300
Cannot set management-vlan different with L3 interface vlan!
先删除管理 VLAN 接口
undo interface vlan-interface 1
管理VLAN要删除掉. 默认是VLAN 1.  
undo management-vlan
再添加新管理VLAN ID
management-vlan 300
再次添加vlan接口
interface vlan-interface 300
ip地址
ip address 192.168.5.101 255.255.255.0
网关
ip gateway 192.168.5.1
HW01_0.xy-yd-3526   : 这是交换机的名称
IP address 192.168.192.168 collision detected, sourced by 0013-d47a-46a9
on Ethernet0/7 of VLAN6 and 0010-e537-fe72 on Ethernet0/7 of VLAN6:  
这是指两个ip地址冲突. 具体在vlan6里, 7号端口下某个交换机上接的2台电脑ip冲突了.
两台mac分别是,0013-d47a-46a9,0010-e537-fe72.
Apr  5 03:38:28:058 2000 H3C ARP/5/DUPIP:- 1 -IP address 192.168.2.33 collision
  detected, sourced by 001b-b14e-cd44 on Ethernet1/0/2 of VLAN20 and d485-64b5-d6
 e2 on Ethernet1/0/2 of VLAN20
%Apr  5 03:28:30:612 2000 H3C PTVL/5/WARNING:- 1 -The link partner of Ethernet1/
 0/15 may be bad,sending lots of error packets !
该告警的含义为,对端设备端口可能出现故障,发送了大量的错误包过来,会影响业务,建议检查两边的端口协商是否一致,如果不一致,调整两边端口协商模式,如果一致,建议更换端口。
看到这些信息后,不要重启设备,收集如下信息:
dis int g1/0/25    //显示3次这个端口的完整信息。

注 意
华为的三层交换机(以S3500系列VRP3.1为例)上要各个VLAN间通信,只需要在VLAN接口视图(注意:不是VLAN视图)下给VLAN配置 IP地址,然后把该VLAN所属的端口相连设备的默认网关设成是该VLAN的iP就可以了,不需要再做其它设置。各个VLAN之间配了IP地址以后,就相当于给三层交换机路由接口配置了IP地址,各个接口都是直连到三层交换机上,就是直连路由,可以直接发现的,不用再配路由协议。

华为三层交换机上进行VLAN的配置,主要就是创建VLAN,端口划分,三层VLAN接口地址配置,静态路由或是RIP协议配置。
添加一个VLAN后,路由表里会默认增加2条Direct路由?
但是如果这个vlan下没有其他网络设备,比如没插网线,那这条direct的路由就不会有,插上就有了(这个折磨了我好长时间)
192.168.9.0/24     DIRECT   0    0           192.168.9.1     Vlan-interface90
192.168.9.1/32     DIRECT   0    0           127.0.0.1       InLoopBack0

配置 vlan 接口之前,首先要创建vlan,在配置管理 vlan 之前,首先要创建vlan
S5024E(二层交换机) 任何时刻只能有一个 VLAN 对应的 VLAN 接口可以设置 IP 地址, VLAN 即为管理 VLAN。
如果您想对 S5000E 进行远程管理,必须设置 S5000E 管理 VLAN 接口的 IP 地址。
三种类型的端口可以共存在一台设备上,但Trunk 端口和Hybrid 端口之间不能直接 切换,只能先设为Access 端口,再设置为其他类型端口。例如:Trunk 端口不能直 接被设置为Hybrid 端口,只能先设为Access 端口,再设置为Hybrid 端口。
 
一些列子
华为三层交换机配置实例一例
服务器1双网卡,内网IP:192.168.0.1,其它计算机通过其代理上网
PORT1属于VLAN1
PORT2属于VLAN2
PORT3属于VLAN3
VLAN1的机器可以正常上网
配置VLAN2的计算机的网关为:192.168.1.254
配置VLAN3的计算机的网关为:192.168.2.254
即可实现VLAN间互联
如果VLAN2和VLAN3的计算机要通过服务器1上网
则需在三层交换机上配置默认路由
系统视图下:ip route-static 0.0.0.0 0.0.0.0 192.168.0.1
然后再在服务器1上配置回程路由
进入命令提示符
route add 192.168.1.0 255.255.255.0 192.168.0.254
route add 192.168.2.0 255.255.255.0 192.168.0.254
这个时候vlan2和vlan3中的计算机就可以通过服务器1访问internet了~

命令如下:
一、组网需求:
交换机配置了4个VLAN,分别为VLAN1,VLAN2,VLAN3,VLAN4,要求VLAN1可以与VLAN2,3,4互访,但是VLAN2,3,4之间不能互访,用Hybrid端口属性实现此功能。
二、组网图:

三、配置步骤:
1.      创建VLAN2
[Quidway]vlan 2
2.      创建VLAN3
[Quidway-vlan2]vlan 3
3.      创建VLAN4
[Quidway-vlan3]vlan 4
4.      进入端口Ethernet1/0/1
[Quidway-vlan4] interface Ethernet1/0/1  
5.      将端口设置为hybrid模式
[Quidway-Ethernet1/0/1]port link-type hybrid
6.      设置端口pvid为1
[Quidway-Ethernet1/0/1]port hybrid pvid vlan 1
7.      允许VLAN1,2,3,4不打标签通过
[Quidway-Ethernet1/0/1]port hybrid vlan 1 to 4 untagged
8.      进入端口Ethernet1/0/2
[Quidway-Ethernet1/0/1]interface Ethernet1/0/2
9.      将端口设置为hybrid模式
[Quidway-Ethernet1/0/2]port link-type hybrid      
10.  设置端口pvid为2
[Quidway-Ethernet1/0/2]port hybrid pvid vlan 2
11.  允许VLAN1,2不打标签通过
[Quidway-Ethernet1/0/2]port hybrid vlan 1 to 2 untagged
12.  进入端口Ethernet1/0/3
[Quidway-Ethernet1/0/2]interface Ethernet1/0/3  
13.  将端口设置为hybrid模式
[Quidway-Ethernet1/0/3]port link-type hybrid                      
14.  设置端口pvid为3
[Quidway-Ethernet1/0/3]port hybrid pvid vlan 3
15.  允许VLAN1,3不打标签通过
[Quidway-Ethernet1/0/3]port hybrid vlan 1 3 untagged
16.  进入端口Ethernet1/0/4
[Quidway-Ethernet1/0/3]interface Ethernet1/0/4
17.  将端口设置为hybrid模式                  
[Quidway-Ethernet1/0/4]port link-type hybrid
18.  设置端口pvid为4
[Quidway-Ethernet1/0/4]port hybrid pvid vlan 4                    
19.  允许VLAN1,4不打标签通过
[Quidway-Ethernet1/0/4]port hybrid vlan 1 4 untagged    
四、配置关键点:
1. 利用交换机以太网端口的Hybrid特性,可以实现PVLAN的功能。
2. 采用Hybrid属性实现的PVLAN功能和PVLAN的工作机制存在较大差异,上述情况只适用于网络流量,网络用户较少的应用

#
结束
更多请:
linux 系统运维  37275208
vmware 虚拟化  166682360
#
本文出自 “dongnan” 博客,请务必保留此出处http://dngood.blog.51cto.com/446195/601873
欢迎关注微信公众号: 运维录
游客

返回顶部