跳转至

Cisco 局域网络设计示例


2013-05-09 by dongnan

目标

设计公司网络拓扑图,学习基础交换机命令、vlantrun、三层交换路由。

环境

  • 模拟器: cisco packet tracer version:5.3.2.0027
  • 虚拟交换机: cisco 3560/2950/2960
  • Vlan: vlan 91 - vlan 93/vlan 200
  • IP: 192.168.0/16

网络拓扑图:

路由相关

vlan 90 交换机为sw9(汇聚层), 再次划分了3个vlan (连接下面的三台交换机,这样又划分了3个广播域)。

命令

sw0(config)#ip routing        # 开启路由,各个vlan之间可以互通
sw0(config)#no ip routing     # 关闭路由,各个vlan之间则不通了
sw1(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.2     # 添加静态路由(默认路由)
sw1(config)#no ip route 0.0.0.0 0.0.0.0              # 删除路由

验证

sw0#show ip route               #显示路由表

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
        * - candidate default, U - per-user static route, o - ODR
        P - periodic downloaded static route
Gateway of last resort is not set
 C    192.168.0.0/24 is directly connected, Vlan200
 C    192.168.10.0/24 is directly connected, Vlan10
 C    192.168.20.0/24 is directly connected, Vlan20
 C    192.168.30.0/24 is directly connected, Vlan30
 C    192.168.40.0/24 is directly connected, Vlan40
 C    192.168.50.0/24 is directly connected, Vlan50
 C    192.168.60.0/24 is directly connected, Vlan60
 C    192.168.70.0/24 is directly connected, Vlan70
 C    192.168.80.0/24 is directly connected, Vlan80
 C    192.168.90.0/24 is directly connected, Vlan90

小结

各个vlan间互通,不但需要设定vlan接口ip地址,而且还需要开启ip routing !

Vlan相关

vlan的功能:

  • 提高网络安全性,阻止未经授权的vlan访问。
  • 缩小广播域,提高网络传输效率。

命令

sw0>                                         #非特权模式
sw0>enable                                   #进入特权模式
sw0#configure terminal                       #进入全局模式
sw0(config)#vlan 200                         #创建并进入vlan视图
sw0(config-vlan)#exit                        #退出vlan视图
sw0(config)#interface fastEthernet 0/24      #进入端口视图
sw0(config-if)#switchport access vlan 200    #设置此端口为vlan 200 (二层口)
sw0(config-if)#exit                          #退出端口视图
sw0(config)#interface vlan 200               #创建并进入vlan接口视图
sw0(config-if)#ip address 192.168.0.2 255.255.255.0     #设置ip地址
sw0(config-if)#no shutdown                              #激活端口
sw0#show vlan id 200                          #查看vlan配置

sw0#show interfaces fastEthernet 0/24         #查看端口配置
sw0#show interfaces vlan 200                  #查看vlan接口
sw0(config)#no vlan 200                       #删除vlan     
sw0(config)#no interface vlan 200             #删除vlan接口

#dhcp relay
sw0(config)#ip dhcp excluded-address 192.168.0.1   #设置 dhcp 服务器ip地址
sw0(config)#int vlan 10                        #进入vlan 接口视图
sw0(config-if)#ip helper-address 192.168.0.1   #指定广播的目的地址

小结

  • 创建vlan
  • vlan分配端口。
  • 创建vlan接口并分配ip地址。
  • 指定vlandhcp中继地址(可选)。

Trunk相关

trunkvlan有什么关系?

  • 当在交换机上划分有多个vlan时,只使用一条链路实现与其他交换机的通信,这就是trunk

不同的交换机相同vlan idvlan是可以互通的,比如在两个交换机上分别划分了两个vlan(10,90), 当两个交换机上的vlan10vlan90如果要互通,就需要在switchAswitchBvlan10的端口级联,vlan90也是这样。 那么如果交换机上划了10个vlan就需要分别连10条线作级联,这样的方法效率太低。

当交换机支持trunk功能的时候,只需要两个交换机之间有一条级联线,并将对应的端口设置为trunk, 这条线路就可以承载交换机上所有vlan的信息,这样的话就算交换机上设了上百个vlan也只用1个端口就解决了。

trunk 应当在相互连接的两台交换机上分别设置,否则trunk将无法生效,同时在核心交换机上必须创建汇聚交换机的全部VLAN ID

命令

sw9>en
sw9#conf ter
sw9(config)#int fa 0/10             #进入端口视图(这里使用了缩写)
sw9(config-if)#switchport mode ?    #? 提供相关帮助,可以看到有三种模式
access   Set trunking mode to ACCESS unconditionally    #接入模式
dynamic  Set trunking mode to dynamically negotiate access or trunk mode  #动态模式
trunk    Set trunking mode to TRUNK unconditionally     #trunk模式
sw9(config-if)#switchport mode trunk                    #指定端口为trunk模式
sw9(config-if)#no shutdown

# sw0/sw9 创建 vlan 91-93 分配端口,设定IP等过程省略。

# sw0 发现多出来下面的3条路由
sw0#show ip route   
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
#...省略
C    192.168.91.0/24 is directly connected, Vlan91
C    192.168.92.0/24 is directly connected, Vlan92
C    192.168.93.0/24 is directly connected, Vlan93

这些命令的作用:

  • sw9(汇聚层)交换机,划分3个vlan (vlan91 vlan92 vlan93)并分配端口,用于分割广播域。
  • 为了传递这些vlan信息,需要将sw9(汇聚层)交换机与sw0(核心层)交换机的级联端口设置为trunk模式。
  • sw0交换机上建立上面的3个vlan(不用指定端口),建立相应的vlan接口并指定接口ip地址。

小结

  • 交换机的级联口都需要设置为trunk
  • 允许所有vlan通过,这是默认的不需设置
  • 三层交换机上,使用trunk就不需要给上边的vlan指定端口啦,因为trunk承载了所有vlan信息
  • 三层交换机上,配置vlan虚接口ip地址后,路由表将添加相关的路由比如

端口相关

二层端口

3560的所有端口缺省的端口都是二层口,分为access port 只能属于一个VLAN。trunk port 可以让多个VLAN通信,不属于任何VLAN。

三层端口

Cisco 三层交换机提供两种类型的三层端口,即逻辑三层vlan端口和物理三层端口(也叫路由口):

  • 逻辑三层vlan端口整合了路由和桥接功能,用于实现vlan之间的线速路由。
  • 物理三层端口,可以在三层交换机上实现类似传统路由的功能,实现端口间的路由。
  • no switchport 命令把二层口转变为三层口的,可以直接配置IP地址。

命令

# 配置三层口
sw2(config)#int fa 0/23                             #进入端口视图
sw2(config-if)#no switchport                        #设置当前端口为三层口
sw2(config-if)#ip address 192.168.0.3 255.255.255.0 #给三层口设置ip地址
sw2(config-if)#no shutdown                          #开启端口
sw2(config-if)#exit                                 #退出端口视图

#添加默认路由,没有匹配的转给sw1
sw2(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.2

# 添加静态路由:192.168.11.0-192.168.17.0 转给sw2                                                  #
sw0(config)#ip route 192.168.11.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.12.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.13.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.14.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.15.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.16.0 255.255.255.0 192.168.0.3
sw0(config)#ip route 192.168.17.0 255.255.255.0 192.168.0.3

这些命令的作用:

  • sw2(三层)交换机,划分7个vlan (vlan11 - vlan17)并分配端口,创建vlan接口并分配ip地址。
  • sw2交换机指定一个三层口(路由口),并配置ip地址。
  • sw2 交换机添加一条静态路由,0.0.0.0/0 下一跳地址为192.168.0.2 (sw1交换机)。
  • sw1(核心)交换机添加7条静态路由,对应sw2交换机上的vlan11 - vlan17的ip地址,下一跳地址为 192.168.0.3(sw2交换机)。
  • sw1交换机与sw2交换机级联的端口加入同一个vlan中,这里为vlan200,否则不通。

小结

  • 三层交换机 no switchport 命令可以指定某端口为三层口, 可以直接添加ip地址。
  • 三层交换机之间级联的端口需在同一个vlan中,否则不通。

其它

sw9#write erase               #是清除启动配置 startup-config
sw9(config-if)#end            #直接返回到全局模式              
sw9#reload                    #重新载入配置
sw9#?                         #键入 ? 获取该视图下所有的命令及其简单描述
sw9#conf?                     #显示匹配的完整命令
configure
sw9#enable password  123456   #设置登录密码
sw9#show version              #查看版本及引导信息
sw9#show running-config       #查看运行设置
sw9#show startup-config       #查看开机设置

参考

cisco 3560 手册

欢迎关注微信公众号: 运维录

Back to top